Carregando...
Ir para o conteúdo principal

Questões de concursos

Confira várias questões de diferentes concursos públicos e responda as perguntas para testar o seu conhecimento.


Minhas questões:

Questões com:

Excluir questões:


Carregando...
Carregando...
Carregando...

Carregando...

Exibindo 1 a 15 de 16 questões.

Salvar em Meus Filtros
Imprimir página - Exibindo 1 a 15
Questões por página:
Q706834

Julgue os itens seguintes a respeito da construção de algoritmos, dos conceitos de variáveis e de bloco de comandos e das estruturas de controle.

Durante a execução de um programa, o conteúdo de uma variável pode mudar ao longo do tempo, no entanto ela só pode armazenar um valor por vez.

Carregando...
Q706833

Julgue os itens seguintes a respeito da construção de algoritmos, dos conceitos de variáveis e de bloco de comandos e das estruturas de controle.

Uma das vantagens de se construir um algoritmo por meio do pseudocódigo é o fato de que a passagem do algoritmo para uma linguagem de programação qualquer se torna uma atividade quase que instantânea.

Carregando...
Q782465

A questão refere-se ao algoritmo abaixo, escrito em uma pseudolinguagem. Considere X um arranjo; length, uma função que devolve o tamanho do arranjo passado como parâmetro. A endentação demarca blocos de comandos.

Qual é a característica principal desse algoritmo?

Carregando...
Q782439

Considere a tabela a seguir, que contém dados do IMC (Índice de Massa Corporal) de uma pessoa, com uma escala típica de valores, dentre as várias existentes.

A fórmula para o cálculo do IMC é

Das expressões abaixo, em pseudocódigo, qual a que expressa corretamente a lógica para calcular e imprimir o IMC dos dois casos extremos da tabela?

Carregando...
Q782464

A questão refere-se ao algoritmo abaixo, escrito em uma pseudolinguagem. Considere X um arranjo; length, uma função que devolve o tamanho do arranjo passado como parâmetro. A endentação demarca blocos de comandos.

Considerando o arranjo X = [5, 2, 4, 6, 1, 3], qual o estado de X após a execução do algoritmo?

Carregando...
Q706641

Julgue os itens subsequentes, relativos à lógica de programação.

O pseudocódigo a seguir, após executado, apresentará como

resultado 2.370.

Carregando...
Q782463

Considerando que um algoritmo pode ser entendido como uma ferramenta para resolver um problema computacional bem especificado, analise as afirmações abaixo.

I - Um algoritmo descreve um procedimento compu-tacional específico para obter uma determinada saída que tem um relacionamento com a entrada do algoritmo.
II - Pode-se analisar a eficiência de um algoritmo em termos de tempo de execução e de espaço ocupado.
III - Quando se analisa o “pior caso” em termos de tempo, tenta-se determinar o limite superior de tempo de execução relacionado com o número de elementos de saída do algoritmo.

Quais estão corretas?

Carregando...
Q706645

Julgue os itens subsequentes, relativos à lógica de programação.

O pseudocódigo a seguir, após executado, apresentará como resultado 13.

funcao X (n) {
se (n == 1 ou n == 2) então
retorne n;
senão
retorne X (n-1) + n * X (n-2);
}
escreva X(4);

Carregando...
Q522827

Considerando a linguagem utilizada na construção de algoritmos, julgue os itens a seguir.

Se o algoritmo para o cálculo da média de determinado aluno utilizar a fórmula média = (P1 + 2*P2) / 3, em que P1 e P2 referem-se, respectivamente, às notas do aluno na primeira e na segunda prova, e se a média mínima necessária para o aluno ser aprovado na disciplina for 4,5, esse aluno será aprovado se obtiver nota 5,0 na primeira prova e 4,0 na segunda prova.

Carregando...
Q522826

Considerando a linguagem utilizada na construção de algoritmos, julgue os itens a seguir.

O algoritmo a seguir fornece como resultado 50 números pares.

início
 cont : inteiro;
 para cont de 1 até 100 faça
 se (cont resto 2) = 0
 entao escreva (cont,"é número par");
 fim se;
 fim para;
fim algoritmo

Carregando...
Q522833

Acerca de funções e procedimentos em subprogramas, julgue os itens que se seguem.

No algoritmo solução1 apresentado a seguir as variáveis X,

A e B são criadas com escopo global; no algoritmo solução2

apresentado após algoritmo solução1, as variáveis A e B são

criadas com escopo global e a variável X com escopo local.

algoritmo solução1
var
 A, B, X : inteiro
início
 leia (A, B)
 X  A
 A  B
 B  X
 escreva (A, B)
Fim algoritmo.
algoritmo solução2
var
 A, B : inteiro
Procedimento TROCA
 var
 X : inteiro
 início
 X  A
 A  B
 B  X
 fim
início
 leia (A, B)
 TROCA
 escreva (A, B)
Fim algoritmo.
Com   

Carregando...
Q786379

O seguinte algoritmo foi concebido na forma de uma pseudo-linguagem (Português Estruturado). Utilize-o para responder à questão.

O valor impresso ao final do algoritmo é igual a

Carregando...
Q358854

No que diz respeito a linguagens de programação e banco de dados, julgue os itens a seguir.

O resultado final do algoritmo em português estruturado

apresentado abaixo é 13524.

X[1]:=4
X[2]:=2
X[3]:=5
X[4]:=3
X[5]:=1
PARA J:=5 ATE 1 PASSO -1 FACA
PARA I:=1 ATE J-1 FACA
SE (X[I] > X[I+1]) ENTAO
AUX:= X[I]
X[I]:=X[I+1]
X[I+1]:=AUX
FIMSE
FIMPARA
FIMPARA
PARA I:=1 ATE 5 FACA
ESCREVA(X[I])
FIMPARA

Carregando...
Q402719

Com relação à lógica de programação, julgue o próximo item.

O valor da variável e no fim da execução do seguinte

algoritmo será 143


Carregando...
Q786377

Considere o seguinte algoritmo, apresentado na forma de uma pseudolinguagem (Português Estruturado), para responder à questão.

Suponha que os dez primeiros valores a serem fornecidos para a leitura de V, quando solicitados, sejam na seguinte ordem:

 
42, 44, 50, 44, 40, 40, 50, 50, 52, 52.

 
Caso o valor lido para variável Q tenha sido 5, o resultado impresso ao final da execução do algoritmo será

Carregando...
GABARITO:

  • 1) Certo
  • 2) Certo
  • 3) C
  • 4) A
  • 5) B
  • 6) Errado
  • 7) B
  • 8) Certo
  • 9) Errado
  • 10) Certo
  • 11) Certo
  • 12) E
  • 13) Errado
  • 14) Certo
  • 15) C
  •  
© Aprova Concursos - Al. Dr. Carlos de Carvalho, 1482 - Curitiba, PR - 0800 727 6282