Carregando...
Ir para o conteúdo principal

Questões de concursos

Confira várias questões de diferentes concursos públicos e responda as perguntas para testar o seu conhecimento.


Minhas questões:

Questões com:

Excluir questões:


Carregando...
Carregando...
Carregando...

Carregando...

Exibindo 31 a 45 de 74 questões.

Salvar em Meus Filtros
Imprimir página - Exibindo 31 a 45
Questões por página:
Q522834

Com relação às estruturas de controle em programas de computador, julgue os itens subsecutivos.

A chamada de uma função para execução é feita citando-se o seu identificador no meio de uma expressão. Uma função é dita recursiva quando chama ela própria.

Carregando...
Q473936

Assinale a opção que apresenta o algoritmo de ordenação com o pior desempenho, considerando-se um vetor de 100 elementos, com valores inteiros ordenados em ordem inversa ao do algoritmo de ordenação.

Carregando...
Q522826

Considerando a linguagem utilizada na construção de algoritmos, julgue os itens a seguir.

O algoritmo a seguir fornece como resultado 50 números pares.

início
 cont : inteiro;
 para cont de 1 até 100 faça
 se (cont resto 2) = 0
 entao escreva (cont,"é número par");
 fim se;
 fim para;
fim algoritmo

Carregando...
Q522833

Acerca de funções e procedimentos em subprogramas, julgue os itens que se seguem.

No algoritmo solução1 apresentado a seguir as variáveis X,

A e B são criadas com escopo global; no algoritmo solução2

apresentado após algoritmo solução1, as variáveis A e B são

criadas com escopo global e a variável X com escopo local.

algoritmo solução1
var
 A, B, X : inteiro
início
 leia (A, B)
 X  A
 A  B
 B  X
 escreva (A, B)
Fim algoritmo.
algoritmo solução2
var
 A, B : inteiro
Procedimento TROCA
 var
 X : inteiro
 início
 X  A
 A  B
 B  X
 fim
início
 leia (A, B)
 TROCA
 escreva (A, B)
Fim algoritmo.
Com   

Carregando...
Q523754

A respeito de algoritmos e estruturas de dados, julgue os próximos itens.

O algoritmo de ordenamento por inserção tem o menor número de trocas quando o vetor está ordenado de forma inversa à ordem do procedimento.

Carregando...
Q522832

Acerca de funções e procedimentos em subprogramas, julgue os itens que se seguem.

A passagem de parâmetro em uma rotina pode ocorrer de duas maneiras: por valor ou por referência. Em se tratando da passagem por valor, alteram-se os valores dos parâmetros que foram passados para a função.

Carregando...
Q337095

Atenção: Para responder às questões de número 31 e 32, considere o algoritmo abaixo.

Se nas duas ocorrências de atribuição do valor 0 à variável p, ou seja, p← 0, for atribuído 1 a esta variável,

Carregando...
Q450885

Acerca de organização de arquivos e métodos de acesso, assinale a opção correta.

Carregando...
Q786379

O seguinte algoritmo foi concebido na forma de uma pseudo-linguagem (Português Estruturado). Utilize-o para responder à questão.

O valor impresso ao final do algoritmo é igual a

Carregando...
Q358854

No que diz respeito a linguagens de programação e banco de dados, julgue os itens a seguir.

O resultado final do algoritmo em português estruturado

apresentado abaixo é 13524.

X[1]:=4
X[2]:=2
X[3]:=5
X[4]:=3
X[5]:=1
PARA J:=5 ATE 1 PASSO -1 FACA
PARA I:=1 ATE J-1 FACA
SE (X[I] > X[I+1]) ENTAO
AUX:= X[I]
X[I]:=X[I+1]
X[I+1]:=AUX
FIMSE
FIMPARA
FIMPARA
PARA I:=1 ATE 5 FACA
ESCREVA(X[I])
FIMPARA

Carregando...
Q402719

Com relação à lógica de programação, julgue o próximo item.

O valor da variável e no fim da execução do seguinte

algoritmo será 143


Carregando...
Q786377

Considere o seguinte algoritmo, apresentado na forma de uma pseudolinguagem (Português Estruturado), para responder à questão.

Suponha que os dez primeiros valores a serem fornecidos para a leitura de V, quando solicitados, sejam na seguinte ordem:

 
42, 44, 50, 44, 40, 40, 50, 50, 52, 52.

 
Caso o valor lido para variável Q tenha sido 5, o resultado impresso ao final da execução do algoritmo será

Carregando...
Q786376

Considere o seguinte algoritmo, apresentado na forma de uma pseudolinguagem (Português Estruturado), para responder à questão.

De acordo com o algoritmo, assinale a alternativa que apresenta, de forma completa, o conjunto de entradas inválidas para a variável Q, caso sejam fornecidas como entrada para o programa.

 

Carregando...
Q402870

Acerca de lógica de programação, programação estruturada e programação orientada a objetos, julgue os itens a seguir.

Tipos de dados estruturados são definidos por meio de

operadores de tipos, também conhecidos como construtores,

utilizados para formar expressões de tipos.

Carregando...
Q349306

Considere o seguinte algoritmo, expresso na forma de

uma pseudolinguagem (Português Estruturado). Suponha

que o valor lido para a variável a seja 2



Ao final da execução do algoritmo, o valor impresso será

igual a:

Carregando...
GABARITO:

  • 31) Certo
  • 32) E
  • 33) Certo
  • 34) Certo
  • 35) Errado
  • 36) Errado
  • 37) E
  • 38) C
  • 39) E
  • 40) Errado
  • 41) Certo
  • 42) C
  • 43) B
  • 44) Certo
  • 45) C
  •  
© Aprova Concursos - Al. Dr. Carlos de Carvalho, 1482 - Curitiba, PR - 0800 727 6282