Carregando...
Ir para o conteúdo principal

Questão: 522833 - CESPE - 2016 - TCE-PA - Auxiliar Técnico - Informática - Cargo 40

Acerca de funções e procedimentos em subprogramas, julgue os itens que se seguem.

No algoritmo solução1 apresentado a seguir as variáveis X,

A e B são criadas com escopo global; no algoritmo solução2

apresentado após algoritmo solução1, as variáveis A e B são

criadas com escopo global e a variável X com escopo local.

algoritmo solução1
var
 A, B, X : inteiro
início
 leia (A, B)
 X  A
 A  B
 B  X
 escreva (A, B)
Fim algoritmo.
algoritmo solução2
var
 A, B : inteiro
Procedimento TROCA
 var
 X : inteiro
 início
 X  A
 A  B
 B  X
 fim
início
 leia (A, B)
 TROCA
 escreva (A, B)
Fim algoritmo.
Com   

Carregando...
GABARITO: Certo
© Aprova Concursos - Al. Dr. Carlos de Carvalho, 1482 - Curitiba, PR - 0800 727 6282